FANDOM


  • I just got this message


    Pokemon Essentials


    Exception: RuntimeErrorMessage: Field Repels is not a positive integerFile PBS/items.txt, line 11,350,"An item that prevents weak wild Pokémon from appearing for 100 steps after its use.",2,0,0,Compiler:219:in `csvPosInt!'Compiler:476:in `pbGetCsvRecord'Compiler:472:in `each'Compiler:472:in `pbGetCsvRecord'Compiler:817:in `pbCompileItems'Compiler:816:in `pbCompilerEachCommentedLine'Compiler:615:in `each_line'Compiler:615:in `pbCompilerEachCommentedLine'Compiler:612:in `open'Compiler:612:in `pbCompilerEachCommentedLine'

    I got this with every item even when i put a new downloaded doc in the files. HELP ME!

      Loading editor
    • I have encountered almost if not the exact same error from giving the player an item. The only way I have found to fix it is by adding "plurals" to all the items. The most recent item.txt file in Pokemon Essential v16 should have them.

        Loading editor
    • what plurals mean?

        Loading editor
    • I have the exact same problem but it still gives the error even after adding "repels" after the "repel" in order of the text (added plurals to all other items too.) If anyone has an answer please share

        Loading editor
    • Does anybody knows to handle this? Its driving me crazy.

      Exception: RuntimeError
      Message: Field Repels is not a positive integer
      File PBS/items.txt, line 1
      1,350,An item that prevents weak wild Pokémon from appearing for 100 steps after its use.,2,0,0,


        • Compiler:219:in `csvPosInt!'
          ** Compiler:476:in `pbGetCsvRecord'
          ** Compiler:472:in `each'
          ** Compiler:472:in `pbGetCsvRecord'
          ** Compiler:817:in `pbCompileItems'
          ** Compiler:816:in `pbCompilerEachCommentedLine'
          ** Compiler:615:in `each_line'
          ** Compiler:615:in `pbCompilerEachCommentedLine'
          ** Compiler:612:in `open'
          ** Compiler:612:in `pbCompilerEachCommentedLine'
        Loading editor
    • Engineer3210, I have the same problem. Don't know what to do. Has anybody found an answer yet? Also, Yes the newer versions have plurals but the problem doesn't get solved by them.

        Loading editor
    • Then something else is missing. Can you post the first few lines of the items.txt?

        Loading editor
    • I have already found a way to handle it. But thanks anyway :)

        Loading editor
    • A FANDOM user
        Loading editor
Give Kudos to this message
You've given this message Kudos!
See who gave Kudos to this message